1
Vote

SharePoint Send Email with Attachment Cutom Action Not Working

description

Hi,

We used Send Email With Attachment codeplex solution in our SharePoint environment and it was working perfectly fine with SharePoint 2010 version of our sites but when we migrated the same solution to SharePoint 2013 , although it appears in custom action in SharePoint designer but doesnt allows users to add the custom action in the workflow. The custom action in existing workflows are causing a deserialization error when we open them in designer. Could you please let us know if we have 2013 compatible designer custom action available.

Regards
Neha

comments

Aozen wrote Oct 27, 2014 at 4:01 PM

Hi Neha,

The version you have will work with 2013, but it requires that you modify the web.config file on each of your web frontend servers. In your web.config file you will find a line:

<authorizedType Assembly="SPD_SendEmailWithAttachment, Version=1.0.0.0, Culture=neutral, PublicKeyToken=acc221d0a4a7db74" Namespace="SPD_SendEmailWithAttachment" TypeName="*" Authorized="True" />

All you need to do is copy this line and move it one level down, so it would be under <authorizedTypes><targetFx>

Neha_Sharma1912 wrote Oct 28, 2014 at 1:45 AM

Thanks for the response

I tried installing the wsp on my dev server so that I can make changes in web config and followed all the instructions as available on
https://sharepointstuff.codeplex.com/wikipage?title=SharePoint%20Designer%20Workflow%20Activity%20-%20Send%20Email%20With%20Attachment&referringTitle=Documentation
I am able to see "Send Email With Attachment Activity" as activated from Central admin on all the web apps wherever I required it
but I am not able to see it in custom action in SharePoint designer